Wednesday, October 23, 2019

Attention Mac Users!

Announcement for Mac Users!

With the release of MacOS Catalina, Apple dropped support for all 32bit applications. Apple will also begin requiring Mac applications be notarized (checked by Apple to ensure they don't contain malware and viruses).

All existing MyMemories kits will need to be rebuilt as 64bit and go through the notarization process with Apple in order to work on MacOS Catalina. This process is going to take a long time to complete since we have over 150,000 kits. New kits created after October 18, 2019 are MacOS Catalina ready.

If you haven't yet upgraded to MacOS Catalina we suggest holding off. If you have already upgraded you will need to use the General Zip files for each kit until we can finish rebuilding all kits.

We have already made My Memories Suite 9 64bit and notarized it. Customers will need to download My Memories Suite 9 Build 152 from their account and install it over the top of their existing software.

We have also made My Memories Suite 8 64bit and notarized. Customers will need to download My Memories Suite 8 Build 107 from their account and install it over the top of their existing software.

Customers using older version of My Memories Suite will need to update to My Memories Suite 8 or newer if they have upgraded to or plan to upgrade to MacOS Catalina. These customers can contact csr@mymemories.com for additional information regarding upgrading and obtain a free copy of My Memories Suite 8.

Thank you!
-MyMemories

2 comments:

Anonymous said...

Will there be a way to know when the various kits have been upgraded? Thanks so much!

sallred said...

New kits are being built with the upgraded 64bit technology. Kits that you've purchased will begin to show up with new downloads links in your account: Win64 Win32 Mac64 so you can tell they are 64bit ready. Kits that haven't been re-built yet will still show Windows Mac links which are only 32bit. And you won't need to worry about kits that you've already installed because it is only the installers that need to be updated if you have to install the kits again for some reason.